Which browsers do you support?

Our themes work on all of the latest browsers and have fall-back support for few older versions of Chrome and Firefox. We do not support IE older than 10.